Getting Started‎ > ‎Downloads‎ > ‎

Prerequisites


Prerequisites


Automated Business Logic depends on the following.  Many of the prerequisites are bundled into the Installer, such as Hibernate and Groovy.  


Required


 Software

 Version

 Usage

 Notes

 IDE Recent  Desirable, though not strictly required

 Note: you need the EE Version for Eclipse

 Related to Groovy
 Java JDK 1.6  Select the JDK from the Java Site
==> Alert: we have seen instances of issues (SHA-1 not available) on Windows with JDK 1.6.0.20; these were resolved with JDK 1.6.0.27


Recommended


 Software

 Version

 Usage

 Notes

 Groovy 1.8 or higher Compile

 Deploy
 Needed for BusLogicIntro (training database), not BusLogicDemo (demo database).  Groovy is totally optional for your own projects.

  
For Eclipse, see Eclipse Groovy Plugin, and select the 1.8 compiler as shown in the thumbnail.



Also Consider...


 Software

 Version

 Usage

 Notes

 Hibernate Hibernate 3.6 Compile

 Deploy
 This is supplied in your install, but you may want to get later versions
 DBMS Per Hibernate Support Compile

 Deploy
 Not required for verification, since HSQL supplied


Comments